Skip to content

v2.0.1

Fixes

  • Fix _ auto-completion in editor. [!995]
  • Make sure settings can be deleted. [!984]
  • Fix overflow for the flow changelog page. [!983]
  • Fix correct display of version in (manatee) settings page. [!932]
  • Fix import of apps with no fields property [!931]
  • Ensure plugin version can still be changed when using a launch-flow. [!916]
  • Disallow use of current application in detached trigger. [!900]
  • Fix an issue with broken scroll functionality on the settings page. [!901]

Misc

  • Add a switch for SET flows to indicate that it should be run when subject is deleted. [!954]
  • Performance for load of a data and fixes some initial login experience woes. [!943]
  • Increase max size of app upload to 64MB. [!918]
22 updates for dependencies
  • Update vitest monorepo to v1.3.1 [!908]
  • Update dependency vue-router to v4.3.0 [!914]
  • Update dependency vue-i18n to v9.10.1 [!925]
  • Update dependency vue to v3.4.21 [!921]
  • Update dependency vue to v3.4.20 [!915]
  • Update dependency vite to v5.1.4 [!907]
  • Update dependency swagger-client to v3.25.4 [!920]
  • Update dependency swagger-client to v3.25.3 [!906]
  • Update dependency sass to v1.71.1 [!905]
  • Update dependency query-string to v9 [!926]
  • Update dependency peggy to v4.0.2 [!904]
  • Update dependency eslint-plugin-vue to v9.22.0 [!913]
  • Update dependency eslint to v8.57.0 [!912]
  • Update dependency dompurify to v3.0.9 [!903]
  • Update dependency blockly to v10.4.2 [!902]
  • Update dependency axios to v1.6.8 [!944]
  • Update dependency @vueuse/rxjs to v10.9.0 [!924]
  • Update dependency @vueuse/rxjs to v10.8.0 [!911]
  • Update dependency @vueuse/core to v10.9.0 [!923]
  • Update dependency @vueuse/core to v10.8.0 [!910]
  • Update dependency @vueuse/components to v10.9.0 [!922]
  • Update dependency @vueuse/components to v10.8.0 [!909]

v2.0.0

Features

Misc

  • Feature/regexp visualization [!653]
  • Update docker Docker tag to v24.0.9 [!881]
20 updates for dependencies
  • Update vitest monorepo to v1.3.0 [!898]
  • Update dependency vue-i18n to v9.9.1 [!880]
  • Update dependency vue to v3.4.19 [!895]
  • Update dependency vue to v3.4.18 [!889]
  • Update dependency vite to v5.1.3 [!894]
  • Update dependency vite to v5.1.1 [!892]
  • Update dependency swagger-client to v3.25.1 [!893]
  • Update dependency sass to v1.71.0 [!897]
  • Update dependency query-string to v8.2.0 [!883]
  • Update dependency prettier to v3.2.5 [!879]
  • Update dependency peggy to v4 [!899]
  • Update dependency monaco-editor to ^0.46.0 [!891]
  • Update dependency marked-base-url to v1.1.3 [!888]
  • Update dependency marked to v12 [!884]
  • Update dependency jsdom to v24 [!869]
  • Update dependency espree to v10.0.1 [!887]
  • Update dependency eslint-plugin-vue to v9.21.1 [!882]
  • Update dependency cronstrue to v2.48.0 [!890]
  • Update dependency blockly to v10.4.1 [!896]
  • Update dependency @vitejs/plugin-vue to v5.0.4 [!886]

v2.0.0-beta2

Fixes

  • Fix editor popups sometimes not being visible [!851]

Features

  • Feature: Add switch to hide .NET languages in new-flow page [!871]

Misc

  • Update docker Docker tag to v24.0.8 [!875]
  • Add switch to disable subject attributes (develop) [!861]
  • Switch to ESM for vite [!849]
  • Remove 'Web' from App names [!848]
  • Update docker Docker tag to v24.0.7 [!824]
49 updates for dependencies
  • Update vitest monorepo to v1.2.2 [!876]
  • Update vitest monorepo to v1.2.1 [!866]
  • Update vitest monorepo to v1.2.0 [!859]
  • Update vitest monorepo to v1.1.3 [!845]
  • Update vitest monorepo to v1.1.1 [!828]
  • Update dependency vue-i18n to v9.9.0 [!847]
  • Update dependency vue to v3.4.5 [!844]
  • Update dependency vue to v3.4.3 [!827]
  • Update dependency vue to v3.4.15 [!865]
  • Update dependency vue to v3.4.13 [!856]
  • Update dependency vue to v3.3.12 [!823]
  • Update dependency vite to v5.0.12 [!864]
  • Update dependency vite to v5.0.11 [!843]
  • Update dependency vite to v5.0.10 [!822]
  • Update dependency swagger-client to v3.25.0 [!846]
  • Update dependency swagger-client to v3.24.6 [!821]
  • Update dependency sass to v1.70.0 [!868]
  • Update dependency sass to v1.69.7 [!842]
  • Update dependency sass to v1.69.6 [!835]
  • Update dependency prettier to v3.2.4 [!863]
  • Update dependency prettier to v3.2.2 [!858]
  • Update dependency moment to v2.30.1 [!837]
  • Update dependency marked to v11.2.0 [!877]
  • Update dependency marked to v11.1.1 [!834]
  • Update dependency jsondiffpatch to ^0.6.0 [!826]
  • Update dependency jsdom to v23 [!789]
  • Update dependency fake-indexeddb to v5.0.2 [!833]
  • Update dependency espree to v10 [!878]
  • Update dependency eslint-plugin-vue to v9.20.1 [!857]
  • Update dependency eslint to v8.56.0 [!825]
  • Update dependency dompurify to v3.0.8 [!841]
  • Update dependency blockly to v10.3.1 [!862]
  • Update dependency axios to v1.6.7 [!874]
  • Update dependency axios to v1.6.5 [!840]
  • Update dependency axios to v1.6.3 [!832]
  • Update dependency @vueuse/rxjs to v10.7.2 [!855]
  • Update dependency @vueuse/rxjs to v10.7.1 [!831]
  • Update dependency @vueuse/core to v10.7.2 [!854]
  • Update dependency @vueuse/core to v10.7.1 [!830]
  • Update dependency @vueuse/components to v10.7.2 [!853]
  • Update dependency @vueuse/components to v10.7.1 [!829]
  • Update dependency @vue/test-utils to v2.4.4 [!873]
  • Update dependency @vue/eslint-config-prettier to v9 [!839]
  • Update dependency @vitejs/plugin-vue to v5.0.3 [!852]
  • Update dependency @vitejs/plugin-vue to v5 [!838]
  • Update dependency @vitejs/plugin-vue to v4.6.2 [!836]
  • Update dependency @rushstack/eslint-patch to v1.7.2 [!872]
  • Update dependency @rushstack/eslint-patch to v1.7.0 [!867]
  • Update dependency @rushstack/eslint-patch to v1.6.1 [!820]

v2.0.0-beta1

Fixes

  • Fix bad 'currentLang' value messing things up [!815]
  • fix flow size overflow [!813]
  • Fix: Ensure header is not shown when sharing submenu is empty [!620]
  • Fix overflow [!628]
  • fix versioning [!652]
  • Fix linting errors [!647]
  • Fix the ability to pin the menu if no user [!629]
  • Fix missing app header when creating a flow [!543]
  • Fix: Change with int64 properties [!533]
  • Fix the color of the checkmark icon [!507]
  • Fix/duplicate subject input [!505]
  • Fix: Minor bugs in favourites [!498]
  • Fix: Table update bug [!492]
  • Fix debounce perf for Home.vue and GlobalSearch.vue [!491]

Features

  • Feature: Favourite management [!501]
  • Feature: Add support for selecting a specific version to download from a Hub [!664]
  • Feature: 2.0 implementation of subject attributes for #793 [!654]
  • Feature: Add test hub connection button [!610]
  • Feature: Better app menu organization [!518]
  • Feature: Indicate if more options than shown in typeahead [!504]
  • feature: favourites [!496]
  • Feature: Introduce the CANSET flow state type to fix #762 [!493]
  • Feature: Vue 3 [!485]
  • Feature: Context sharing in state flows [!480]

Misc

  • Add UI for configuring secrets. [!783]
  • Center the 404 page div [!790]
  • Actionable warnings/messages for flow-editor [!725]
  • Mutated path UI [!645]
  • Upgrade eslint prettier [!648]
  • Replace jobs text with progress [!621]
  • Feature/better ui path parser [!565]
  • Attempt w new licensefinder image [!589]
  • Add new header and reduce footer to [!574]
  • Push a route in definition provider [!573]
  • Make router.js a bit more DRY and allow easy disabling of title localization [!547]
  • Switch Modal to listen to global keypresses [!560]
  • Monaco editor stores line with cursor in url and restores on load [!559]
  • FieldTest output copy to clipboard [!558]
  • Restore default i18n pushing in three ways [!542]
  • Codelens for fields in the editor [!531]
  • Remove keys from router-view elements to allow views to reuse components… [!540]
  • Use new licensefinder [!530]
  • Switch node versions to 18 [!516]
  • Update registry.gitlab.com/sirenia/goenv Docker tag to v1.16 [!509]
  • Configure Renovate [!508]
  • Error occurred while attempting to update a state flow subject or action [!506]
  • Type ahead to show already used subjects [!497]
  • Enable SAST checkers [!494]
254 updates for dependencies
  • Update vitest monorepo to v1 (major) [!812]
  • Update vitest monorepo to v0.34.6 [!721]
  • Update vitest monorepo to v0.34.5 [!716]
  • Update vitest monorepo to v0.34.4 [!693]
  • Update vitest monorepo to v0.34.3 [!678]
  • Update vitest monorepo to v0.34.2 [!668]
  • Update vitest monorepo to v0.32.4 [!609]
  • Update vitest monorepo to v0.32.3 [!608]
  • Update vitest monorepo to v0.32.2 [!588]
  • Update vitest monorepo to v0.31.4 [!575]
  • Update vitest monorepo to v0.31.3 [!572]
  • Update vitest monorepo to v0.31.2 [!571]
  • Update vitest monorepo to v0.31.1 [!556]
  • Update vitest monorepo to ^0.34.0 [!642]
  • Update vitest monorepo to ^0.33.0 [!615]
  • Update vitest monorepo to ^0.32.0 [!582]
  • Update vitest monorepo to ^0.31.0 [!525]
  • Update dependency vue-router to v4.2.5 [!715]
  • Update dependency vue-router to v4.2.4 [!612]
  • Update dependency vue-router to v4.2.2 [!569]
  • Update dependency vue-router to v4.2.1 [!555]
  • Update dependency vue-router to v4.2.0 [!541]
  • Update dependency vue-i18n to v9.8.0 [!798]
  • Update dependency vue-i18n to v9.7.1 [!787]
  • Update dependency vue-i18n to v9.7.0 [!766]
  • Update dependency vue-i18n to v9.6.3 [!763]
  • Update dependency vue-i18n to v9.6.2 [!756]
  • Update dependency vue-i18n to v9.5.0 [!724]
  • Update dependency vue-i18n to v9.4.1 [!704]
  • Update dependency vue-i18n to v9.4.0 [!698]
  • Update dependency vue-i18n to v9.3.0 [!696]
  • Update dependency vue to v3.3.9 [!786]
  • Update dependency vue to v3.3.8 [!768]
  • Update dependency vue to v3.3.7 [!752]
  • Update dependency vue to v3.3.6 [!746]
  • Update dependency vue to v3.3.4 [!553]
  • Update dependency vue to v3.3.2 [!546]
  • Update dependency vue to v3.3.11 [!806]
  • Update dependency vue to v3.3.1 [!539]
  • Update dependency vite to v5.0.8 [!816]
  • Update dependency vite to v5.0.7 [!805]
  • Update dependency vite to v5.0.4 [!794]
  • Update dependency vite to v5.0.2 [!785]
  • Update dependency vite to v5 [!782]
  • Update dependency vite to v4.5.0 [!748]
  • Update dependency vite to v4.4.9 [!626]
  • Update dependency vite to v4.4.2 [!614]
  • Update dependency vite to v4.4.11 [!727]
  • Update dependency vite to v4.3.9 [!568]
  • Update dependency vite to v4.3.8 [!552]
  • Update dependency vite to v4.3.7 [!551]
  • Update dependency vite to v4.3.6 [!548]
  • Update dependency vite to v4.3.5 [!522]
  • Update dependency vite to v4.3.4 [!517]
  • Update dependency uuid to v9.0.1 [!697]
  • Update dependency swagger-client to v3.24.5 [!765]
  • Update dependency swagger-client to v3.24.0 [!762]
  • Update dependency swagger-client to v3.23.1 [!742]
  • Update dependency swagger-client to v3.23.0 [!737]
  • Update dependency swagger-client to v3.22.3 [!714]
  • Update dependency swagger-client to v3.22.2 [!710]
  • Update dependency swagger-client to v3.22.1 [!708]
  • Update dependency swagger-client to v3.20.2 [!692]
  • Update dependency swagger-client to v3.20.0 [!625]
  • Update dependency swagger-client to v3.19.8 [!561]
  • Update dependency swagger-client to v3.19.10 [!587]
  • Update dependency sass to v1.69.5 [!751]
  • Update dependency sass to v1.69.4 [!745]
  • Update dependency sass to v1.69.3 [!741]
  • Update dependency sass to v1.69.0 [!736]
  • Update dependency sass to v1.68.0 [!718]
  • Update dependency sass to v1.67.0 [!707]
  • Update dependency sass to v1.66.1 [!672]
  • Update dependency sass to v1.65.1 [!663]
  • Update dependency sass to v1.64.2 [!641]
  • Update dependency sass to v1.63.6 [!596]
  • Update dependency sass to v1.63.5 [!595]
  • Update dependency sass to v1.63.4 [!584]
  • Update dependency sass to v1.63.3 [!583]
  • Update dependency sass to v1.63.2 [!581]
  • Update dependency prettier to v3.1.1 [!804]
  • Update dependency prettier to v3.1.0 [!780]
  • Update dependency prettier to v3.0.3 [!686]
  • Update dependency prettier to v3.0.2 [!667]
  • Update dependency pinia to v2.1.7 [!740]
  • Update dependency pinia to v2.1.6 [!635]
  • Update dependency pinia to v2.1.4 [!586]
  • Update dependency pinia to v2.1.3 [!564]
  • Update dependency pinia to v2.0.36 [!532]
  • Update dependency node to v20 [!759]
  • Update dependency monaco-editor to ^0.45.0 [!811]
  • Update dependency monaco-editor to ^0.44.0 [!735]
  • Update dependency monaco-editor to ^0.43.0 [!662]
  • Update dependency monaco-editor to ^0.41.0 [!640]
  • Update dependency monaco-editor to ^0.40.0 [!613]
  • Update dependency monaco-editor to ^0.39.0 [!580]
  • Update dependency monaco-editor to ^0.38.0 [!524]
  • Update dependency marked-base-url to v1.1.2 [!793]
  • Update dependency marked-base-url to v1.1.1 [!777]
  • Update dependency marked-base-url to v1.1.0 [!706]
  • Update dependency marked-base-url to v1.0.8 [!691]
  • Update dependency marked-base-url to v1.0.7 [!685]
  • Update dependency marked-base-url to v1.0.6 [!657]
  • Update dependency marked-base-url to v1.0.5 [!624]
  • Update dependency marked to v9.1.6 [!764]
  • Update dependency marked to v9.1.4 [!760]
  • Update dependency marked to v9.1.3 [!750]
  • Update dependency marked to v9.1.2 [!739]
  • Update dependency marked to v9.1.0 [!734]
  • Update dependency marked to v9.0.3 [!713]
  • Update dependency marked to v9.0.2 [!703]
  • Update dependency marked to v9 [!699]
  • Update dependency marked to v8.0.1 [!690]
  • Update dependency marked to v8 [!687]
  • Update dependency marked to v7.0.5 [!677]
  • Update dependency marked to v7.0.4 [!666]
  • Update dependency marked to v7.0.2 [!656]
  • Update dependency marked to v7.0.1 [!651]
  • Update dependency marked to v7 [!644]
  • Update dependency marked to v5.1.2 [!634]
  • Update dependency marked to v5.1.1 [!611]
  • Update dependency marked to v5 [!515]
  • Update dependency marked to v11.1.0 [!817]
  • Update dependency marked to v11.0.1 [!803]
  • Update dependency marked to v11 [!800]
  • Update dependency marked to v10 [!781]
  • Update dependency jwt-decode to v4 [!758]
  • Update dependency jsondiffpatch to ^0.5.0 [!671]
  • Update dependency jsdom to v22 [!529]
  • Update dependency jsdom to v21.1.2 [!511]
  • Update dependency idb to v8 [!799]
  • Update dependency highlight.js to v11.9.0 [!733]
  • Update dependency fomantic-ui-css to v2.9.3 [!689]
  • Update dependency flat to v6.0.1 [!712]
  • Update dependency flat to v6 [!709]
  • Update dependency fake-indexeddb to v5.0.1 [!749]
  • Update dependency fake-indexeddb to v5 [!743]
  • Update dependency fake-indexeddb to v4.0.2 [!623]
  • Update dependency espree to v9.6.1 [!622]
  • Update dependency espree to v9.6.0 [!607]
  • Update dependency espree to v9.5.2 [!521]
  • Update dependency eslint-plugin-vue to v9.19.2 [!797]
  • Update dependency eslint-plugin-vue to v9.18.1 [!755]
  • Update dependency eslint-plugin-vue to v9.17.0 [!661]
  • Update dependency eslint-plugin-vue to v9.16.1 [!639]
  • Update dependency eslint-plugin-vue to v9.15.1 [!598]
  • Update dependency eslint-plugin-vue to v9.15.0 [!594]
  • Update dependency eslint-plugin-vue to v9.14.1 [!567]
  • Update dependency eslint-plugin-vue to v9.14.0 [!563]
  • Update dependency eslint-plugin-vue to v9.13.0 [!549]
  • Update dependency eslint-plugin-vue to v9.12.0 [!537]
  • Update dependency eslint-plugin-vue to v9.11.1 [!520]
  • Update dependency eslint to v8.55.0 [!796]
  • Update dependency eslint to v8.54.0 [!767]
  • Update dependency eslint to v8.52.0 [!747]
  • Update dependency eslint to v8.51.0 [!732]
  • Update dependency eslint to v8.50.0 [!717]
  • Update dependency eslint to v8.49.0 [!695]
  • Update dependency eslint to v8.48.0 [!683]
  • Update dependency eslint to v8.47.0 [!660]
  • Update dependency eslint to v8.46.0 [!627]
  • Update dependency eslint to v8.44.0 [!606]
  • Update dependency eslint to v8.43.0 [!593]
  • Update dependency eslint to v8.42.0 [!576]
  • Update dependency eslint to v8.41.0 [!562]
  • Update dependency eslint to v8.40.0 [!523]
  • Update dependency dompurify to v3.0.6 [!720]
  • Update dependency dompurify to v3.0.5 [!619]
  • Update dependency dompurify to v3.0.4 [!603]
  • Update dependency dompurify to v3.0.3 [!519]
  • Update dependency cronstrue to v2.47.0 [!795]
  • Update dependency cronstrue to v2.44.0 [!779]
  • Update dependency cronstrue to v2.41.0 [!754]
  • Update dependency cronstrue to v2.32.0 [!694]
  • Update dependency cronstrue to v2.31.0 [!670]
  • Update dependency cronstrue to v2.29.0 [!659]
  • Update dependency cronstrue to v2.28.0 [!618]
  • Update dependency cronstrue to v2.27.0 [!534]
  • Update dependency blockly to v10.3.0 [!810]
  • Update dependency blockly to v10.2.2 [!738]
  • Update dependency blockly to v10.2.1 [!726]
  • Update dependency blockly to v10.2.0 [!723]
  • Update dependency blockly to v10.1.3 [!676]
  • Update dependency blockly to v10.1.2 [!665]
  • Update dependency blockly to v10.1.1 [!658]
  • Update dependency blockly to v10.0.2 [!632]
  • Update dependency blockly to v10.0.1 [!617]
  • Update dependency blockly to v10 [!602]
  • Update dependency axios to v1.6.2 [!771]
  • Update dependency axios to v1.6.0 [!753]
  • Update dependency axios to v1.5.1 [!719]
  • Update dependency axios to v1.5.0 [!682]
  • Update dependency astring to v1.8.6 [!570]
  • Update dependency astring to v1.8.5 [!554]
  • Update dependency @zxcvbn-ts/language-en to v3.0.2 [!702]
  • Update dependency @zxcvbn-ts/language-common to v3.0.4 [!701]
  • Update dependency @zxcvbn-ts/language-common to v3.0.3 [!578]
  • Update dependency @zxcvbn-ts/language-common to v3.0.2 [!545]
  • Update dependency @zxcvbn-ts/language-common to v3.0.1 [!536]
  • Update dependency @zxcvbn-ts/core to v3.0.4 [!700]
  • Update dependency @zxcvbn-ts/core to v3.0.3 [!631]
  • Update dependency @zxcvbn-ts/core to v3.0.2 [!577]
  • Update dependency @zxcvbn-ts/core to v3.0.1 [!535]
  • Update dependency @zxcvbn-ts/core to v3 [!526]
  • Update dependency @vueuse/rxjs to v10.7.0 [!809]
  • Update dependency @vueuse/rxjs to v10.6.1 [!778]
  • Update dependency @vueuse/rxjs to v10.5.0 [!731]
  • Update dependency @vueuse/rxjs to v10.4.1 [!681]
  • Update dependency @vueuse/rxjs to v10.3.0 [!638]
  • Update dependency @vueuse/rxjs to v10.2.1 [!601]
  • Update dependency @vueuse/rxjs to v10.2.0 [!592]
  • Update dependency @vueuse/core to v10.7.0 [!808]
  • Update dependency @vueuse/core to v10.6.1 [!773]
  • Update dependency @vueuse/core to v10.5.0 [!730]
  • Update dependency @vueuse/core to v10.4.1 [!680]
  • Update dependency @vueuse/core to v10.2.1 [!600]
  • Update dependency @vueuse/core to v10.2.0 [!591]
  • Update dependency @vueuse/components to v10.7.0 [!807]
  • Update dependency @vueuse/components to v10.6.1 [!772]
  • Update dependency @vueuse/components to v10.5.0 [!729]
  • Update dependency @vueuse/components to v10.4.1 [!679]
  • Update dependency @vueuse/components to v10.2.1 [!599]
  • Update dependency @vueuse/components to v10.2.0 [!590]
  • Update dependency @vuelidate/validators to v2.0.4 [!675]
  • Update dependency @vuelidate/validators to v2.0.3 [!605]
  • Update dependency @vuelidate/core to v2.0.3 [!604]
  • Update dependency @vue/test-utils to v2.4.3 [!792]
  • Update dependency @vue/test-utils to v2.4.2 [!776]
  • Update dependency @vue/test-utils to v2.4.1 [!630]
  • Update dependency @vue/test-utils to v2.4.0 [!597]
  • Update dependency @vitejs/plugin-vue to v4.5.2 [!801]
  • Update dependency @vitejs/plugin-vue to v4.5.1 [!791]
  • Update dependency @vitejs/plugin-vue to v4.5.0 [!770]
  • Update dependency @vitejs/plugin-vue to v4.4.0 [!728]
  • Update dependency @vitejs/plugin-vue to v4.3.4 [!684]
  • Update dependency @vitejs/plugin-vue to v4.3.3 [!674]
  • Update dependency @vitejs/plugin-vue to v4.3.1 [!669]
  • Update dependency @vitejs/plugin-vue to v4.2.3 [!544]
  • Update dependency @vitejs/plugin-vue to v4.2.2 [!538]
  • Update dependency @types/lodash to v4.14.202 [!784]
  • Update dependency @types/lodash to v4.14.201 [!769]
  • Update dependency @types/lodash to v4.14.200 [!744]
  • Update dependency @types/lodash to v4.14.199 [!711]
  • Update dependency @types/lodash to v4.14.198 [!688]
  • Update dependency @types/lodash to v4.14.197 [!655]
  • Update dependency @types/lodash to v4.14.196 [!633]
  • Update dependency @types/lodash to v4.14.195 [!566]
  • Update dependency @rushstack/eslint-patch to v1.6.0 [!788]
  • Update dependency @rushstack/eslint-patch to v1.5.1 [!722]
  • Update dependency @rushstack/eslint-patch to v1.4.0 [!705]
  • Update dependency @rushstack/eslint-patch to v1.3.3 [!650]
  • Update dependency @rushstack/eslint-patch to v1.3.2 [!585]
  • Update dependency @rushstack/eslint-patch to v1.3.1 [!579]
  • Update dependency @rushstack/eslint-patch to v1.3.0 [!557]